Login to BRIX

Japanese-English Translation

Java is required on your computer to make recordings.
  • Mac OSX Users: The Java machine is already installed. The Firefox browser works best with BRIX.
  • Windows Users: Install Java from Java SE Downloads. Use IE or Firefox.
Flash Player 9 or higher is required to play recordings.

©2000-2008 College of Languages, Linguistics, and Literature , University of Hawaii at Manoa
Please send us your comments.